First unread post8 posts Page 1 of 1
Unread postby vertigo » 15 Mar 2019 09:19
I've dug through the settings multiple times and can't find a way to disable subtitles by default. They can be hidden (Show/Hide Subtitles (Alt+H)), but that's not what I want, because then they have to be switched on then switched (Alt+L) as needed. What I'd like is an option to select the "Off" option (L -> Off) by default so that when I play a video, subtitles don't show but I can press Alt+L to cycle through them. And ideally, I'd like an option to do this except when a subtitle has a forced flag, in which case it should default to that track. So, if there's a forced subtitle, select that one, otherwise, default to off (no subtitle).
Unread postby Dreamer » 16 Mar 2019 05:49
I think it's not possible.

To prefer forced subs: in Preferences > subtitles > language/sync/other > Preferred languages add:

forced

or together with your language:

forced&english

Or you can use LAV splitter for mkv and configure it to load desired subs for any audio.
Unread postby vertigo » 16 Mar 2019 09:36
Thanks. I had the default in there:
Code: Select all
forced&english default&english encc eng en english
and tried removing all but forced&english and even tried just using forced with no other conditions, but none of it worked. Subtitles still default to on no matter what.

As for configuring the LAV filter, I don't see anything related to subtitles in its configuration, nor am I sure about how to use LAV with MKVs (I assume Filter Control > Source/Splitter > Filter Management > and check "LAV Audio Decoder under "DirectShow Filter List" and MKV under "Source/Splitter," but I feel like that's not right).
Unread postby Dreamer » 16 Mar 2019 10:44
You can't use all conditions, just use forced&english - if you use also english, if the forced subs are missing english are used, but even if none of these are included, first are used anyway, it's unusable, it's just to prefer, no to "use these only and ignore others".

I think the only way is to use the LAV splitter, it works perfect, here is the guide:

viewtopic.php?f=9&t=3474&p=8425&hilit=lav+splitter#p8425

You can set LAV to use English forced subs for English audio, or use NO subs for English audio and so on, it looks complicated, but it's quite easy - and you can find help if you need it, e.g. videohelp forum is good.

Try this for LAV:

Audio:
eng

Subtitles:
*:eng@forced *:eng@Forced *:off

So, if the forced subs are available, use these, if not, use none, for any language. If you don't want to use any subtitles always, use just:
*:off

I just checked it with mkv and it works.

The options: Subtitle selection mode: "only forced subtitles" and "no subtitles" works too.
Unread postby vertigo » 16 Mar 2019 17:28
Thanks. That seems to be working pretty well. I'm just using the "only forced subtitles" selection mode, since it seems to work and seems to be the same as the pasting the string in the box. At first I disabled the "enable automatic forced subtitle stream" option since it was cluttering the subtitle choices and I was worried it would end up showing subs when I didn't want them or screwing something up, but I tested it on a couple movies I recently watched that were frustrating because they didn't have a forced track, so I had to switch back and forth while watching, and that option did perfectly, only showing the subs I'd want to see. I'm guessing they must be tagged in a way the default filter can't interpret but LAV can, which is great (though it has the drawback of keeping me from knowing which movies have the problem so I can fix them).

I do wish I could get rid of the separate "no subtitles" entry in the list, which is redundant to the "off" option, so now there's always one more "subtitle" to cycle through. I also wish I could reorder it so the auto forced track would be first, but that's less important. One thing I noticed is that one of the movies I tested still defaulted to the first built-in subtitle track instead of the auto forced one, and every time I pasted the string you provided into the box, closed the player, then reopened the movie it would default back to that track again, even if I'd switched it to a different one. I tried some other movies and none of them behaved this way, so not sure what's special about this particular movie. Thinking maybe it had something to do with the first track having semi-forced parts (one of the movies that doesn't have a forced track but only the parts that should be forced play using LAV's auto forced feature), I tried the other movie like that, and it kept defaulting to the "no subtitles" selection, even when I switched it and closed then reopened PotPlayer. It finally stuck and reopened with the auto forced track selected after I selected the one before it and closed and reopened PP. So there definitely seems to be some bugs with it. Guess I'll have to play around with it and keep an eye on it.

It's really too bad that a year and a half after your thread regarding this same issue, it still exists and requires this workaround fix, especially considering PP makes such a point about how all the built-in stuff is recommended, but then you can't do such a basic thing with it and have to use an external filter. I hope the dev changes their mind about it and implements it into PP's core functionality, but unfortunately I don't think it's going to happen.
Unread postby vertigo » 12 Apr 2019 14:17
Just to do a quick update on this, after using it this way for a while now. It's definitely nice to not have to turn subtitles off every time I play a video that has them, but there is one really big difference that is pretty frustrating, which is that when using LAV splitter for subs, every time you cycle through them it causes the video to essentially pause for a half second to a second. So whereas before, if I couldn't understand something, I'd simply jump back a few seconds and do Alt+L to enable subs, then hit it again however many times were necessary to turn them back off while continuing to watch, now I have to jump back a bit further to allow for time to turn them on, because the video becomes unwatchable while cycling them. It's not really a big deal, just kind of annoying and certainly not as fluid and unobtrusive as it was before. So while it's better than it was before, I would still prefer an option to be able to just disable them by default unless they're forced.
Unread postby Dreamer » 13 Apr 2019 03:41
When you need to switch subs manually? With LAV the subs should be loaded only if needed.

You can try the videohelp forum if you need help with the LAV splitter.

Another hint, try the fMod skin with the audio and subs button, you can easily select your subtitles, or disable, just with 2 clicks.
Unread postby Dreamer » 17 Apr 2019 07:00
vertigo wrote:when using LAV splitter for subs, every time you cycle through them it causes the video to essentially pause for a half second to a second.

Now I see what you mean, you are right, it's quite annoying, not sure if it's a LAV or PotPlayer issue. :?
First unread post8 posts Page 1 of 1

Login

Who is online

Users browsing this forum: No registered users and 1 guest