First unread post6 posts Page 1 of 1
Unread postby iccfish » 25 Sep 2019 11:39
With latest update(1.7.20538), running on windows 10 1903 with AMD RX5700xt, HEVC video file can not play anymore.

Video decode shows currently using 'HEVC-Native D3D9 DXVA Decoder(VLD) - AMD Radeon RX 5700', but video file can not play anymore, audio play normally, but screen black.

BTW, Hareware acceleration(DXVA) in built-in video decoder settings can not be enabled. If enabled, PotPlayer will hangs up on begin playback, this issue bothers me for a long time. If I check 'Prioritize D3D11 DXVA', I'll get a full 'green' screen.
Unread postby iccfish » 25 Sep 2019 13:33
And here's one more issue: in settings, Video -> Fullscreen exclusive mode, must be 'disable'.
PotPlayer will hangs up when I tring to change window to full screen if this option was set to 'Enable: Fast' or 'Enable: A little slow'. So 10bit video rendering was impossible. :|
Unread postby P.Mario » 25 Sep 2019 15:56
iccfish wrote:With latest update(1.7.20538), running on windows 10 1903 with AMD RX5700xt, HEVC video file can not play anymore.

Video decode shows currently using 'HEVC-Native D3D9 DXVA Decoder(VLD) - AMD Radeon RX 5700', but video file can not play anymore, audio play normally, but screen black.

BTW, Hareware acceleration(DXVA) in built-in video decoder settings can not be enabled. If enabled, PotPlayer will hangs up on begin playback, this issue bothers me for a long time. If I check 'Prioritize D3D11 DXVA', I'll get a full 'green' screen.

I've done this; hope this'll work for you too
https://i.imgur.com/PmPTsU4.jpg
If you don't see ffmpeg64.dll option, uninstall potplayer and reinstall it and in the last pannel of installation check "install additional codecs" (check all 3 checkboxes).
Unread postby iccfish » 26 Sep 2019 02:30
P.Mario wrote:
iccfish wrote:With latest update(1.7.20538), running on windows 10 1903 with AMD RX5700xt, HEVC video file can not play anymore.

Video decode shows currently using 'HEVC-Native D3D9 DXVA Decoder(VLD) - AMD Radeon RX 5700', but video file can not play anymore, audio play normally, but screen black.

BTW, Hareware acceleration(DXVA) in built-in video decoder settings can not be enabled. If enabled, PotPlayer will hangs up on begin playback, this issue bothers me for a long time. If I check 'Prioritize D3D11 DXVA', I'll get a full 'green' screen.

I've done this; hope this'll work for you too
https://i.imgur.com/PmPTsU4.jpg
If you don't see ffmpeg64.dll option, uninstall potplayer and reinstall it and in the last pannel of installation check "install additional codecs" (check all 3 checkboxes).



Thanks for your reply. But ffmpeg was S/W decoder.

Finally I found what's the problem. I use DxvaChecker to change driver settings, found H265/HEVC was set to '0'.
I changed it to '1', problem solved.

But the issue 'Fullscreen exclusive mode' can not set to 'Enable' or PotPlayer will hangs up still exist.
Unread postby P.Mario » 26 Sep 2019 14:42
iccfish wrote:
P.Mario wrote:
iccfish wrote:With latest update(1.7.20538), running on windows 10 1903 with AMD RX5700xt, HEVC video file can not play anymore.

Video decode shows currently using 'HEVC-Native D3D9 DXVA Decoder(VLD) - AMD Radeon RX 5700', but video file can not play anymore, audio play normally, but screen black.

BTW, Hareware acceleration(DXVA) in built-in video decoder settings can not be enabled. If enabled, PotPlayer will hangs up on begin playback, this issue bothers me for a long time. If I check 'Prioritize D3D11 DXVA', I'll get a full 'green' screen.

I've done this; hope this'll work for you too
https://i.imgur.com/PmPTsU4.jpg
If you don't see ffmpeg64.dll option, uninstall potplayer and reinstall it and in the last pannel of installation check "install additional codecs" (check all 3 checkboxes).



Thanks for your reply. But ffmpeg was S/W decoder.

Finally I found what's the problem. I use DxvaChecker to change driver settings, found H265/HEVC was set to '0'.
I changed it to '1', problem solved.

But the issue 'Fullscreen exclusive mode' can not set to 'Enable' or PotPlayer will hangs up still exist.

Glad the problem about hevc decoder was solved for you.
honestly, "fullscreen exclusive mode" was always a pain for me, in all versions that I tried, I leave that disabled.
Dxvachecker ?? I didn't know there was such a software to determine dxva decoders in video cards. thanks, I'm using it now.
Unread postby iccfish » 27 Sep 2019 00:54
P.Mario wrote:Glad the problem about hevc decoder was solved for you.
honestly, "fullscreen exclusive mode" was always a pain for me, in all versions that I tried, I leave that disabled.
Dxvachecker ?? I didn't know there was such a software to determine dxva decoders in video cards. thanks, I'm using it now.


I can not use 'fullscreen exclusive mode' built in PotPlayer. Therefore 10bit playback is not possible.

But I'm using MadVR as rendering engine and it works with 'Windowed exclusive mode' and 10bit very well.
First unread post6 posts Page 1 of 1

Login

Who is online

Users browsing this forum: No registered users and 9 guests