Unread postby fuccaneer » 21 Sep 2019 10:03
Update 1.7.20538 64bit breaks HVEC decoding
Tried hardware and software acceleration and switching default HVEC decoders but the videos just play audio with the video render never finishing.
Couldnt figure out how to roll back.

UPDATED TO REFLECT 64BIT VERSION. 32bit version of 1.7.20538 seems to play HVEC without issue.
Unread postby V@no » 23 Sep 2019 09:10
I'm getting on 32bit player
S/W HEVC(H265) decoding not supported.\NPlease click 'Find Codec' to install the appropriate codec


DXVA is enabled.
How to replace ugly new yellow icon in PotPlayer with the old one or your own
Display breadcrumbs links on this forum and a link to latest PotPlayer beta.
Unread postby DVB Support » 23 Sep 2019 20:58
V@no wrote:I'm getting on 32bit player
S/W HEVC(H265) decoding not supported.\NPlease click 'Find Codec' to install the appropriate codec


DXVA is enabled.


Built-in HEVC decoding was disabled in S/W mode with the latest release.So when you saw this message means you need to have a HEVC decode capable GPU to use Built-in HEVC H/W decoder.
Unread postby P.Mario » 24 Sep 2019 04:49
I've done this setting and it worked for me:
http://uupload.ir/files/osx8_annotation_2019-09-20_224316.jpg
Unread postby V@no » 24 Sep 2019 07:19
DVB Support wrote:Built-in HEVC decoding was disabled in S/W mode with the latest release.So when you saw this message means you need to have a HEVC decode capable GPU to use Built-in HEVC H/W decoder.

I thought DXVA is hardware decoding, is it not? It worked fine in previous versions.
Anyway, using "find codec" button downloaded codec, installed it and now it works.
How to replace ugly new yellow icon in PotPlayer with the old one or your own
Display breadcrumbs links on this forum and a link to latest PotPlayer beta.
Unread postby DVB Support » 24 Sep 2019 09:47
V@no wrote:
DVB Support wrote:Built-in HEVC decoding was disabled in S/W mode with the latest release.So when you saw this message means you need to have a HEVC decode capable GPU to use Built-in HEVC H/W decoder.

I thought DXVA is hardware decoding, is it not? It worked fine in previous versions.
Anyway, using "find codec" button downloaded codec, installed it and now it works.


What you don't understand is that the default Built-in HEVC decoder in the latest release requires a HEVC decode capable GPU to run in H/W Mode.(Because it can't run in S/W Mode anymore!) So according to the message, you don't have a GPU card like this, do you?
Unread postby V@no » 25 Sep 2019 08:18
I sure do: Geforce RTX 2080 Ti
Before the update player was using GPU (taskmanger and MSI Afterburner showed around 5-15% usage when PotP was playing videos)
So whatever changed in last version seem to require additional codec, which I assume is the same codec that the installer asks about at the end, and in my case evidently failed to install even though I kept the default checkbox checked to install it.
How to replace ugly new yellow icon in PotPlayer with the old one or your own
Display breadcrumbs links on this forum and a link to latest PotPlayer beta.
Unread postby DVB Support » 25 Sep 2019 09:59
Ok, now everything is clear.It seems that there are some issues in the codes of the new built-in HEVC H/W decoder which needs to be fixed by the author.PotPlayer additional codec in the last step of the installer can be downloaded and installed manually from this link, viewtopic.php?f=5&t=19498#p25088
But in your case this problem is not about the additional codec.
Unread postby fireattack » 12 Nov 2019 16:53
I also have issues with HEVC decoding, now it will always use HW decoding even if you disable it.

On 1.7.20977 x86.

Login

Who is online

Users browsing this forum: No registered users and 5 guests

cron