6 posts Page 1 of 1
Postby Dreamer » 06 Sep 2017 21:49
I'm not sure if it's a bug, but in the new version, if the custom size and position is used on startup, in the top-right corner, video size is adapted vertically for title bar and navigation bar, it's moved a bit down, but it's not adapted horizontally, so the playlist is off screen.

When the playback is started, all toolbars and playlist are auto-hidden and the correct window position and size from preferences is used.

Since the window is adapted vertically, I think it should adapt also horizontally.

Workaround is possible only by changing the position to top-left corner, or set the startup position a bit left, then playlist will be visible on startup, but if playback starts, window size will be changed and it won't be in the top-right corner.

Another workaround is to disable and re-enable playlist, with button or hotkey, then the position is corrected, playlist is visible and after playback start the window pos. and size from preferences is used correctly.
Postby 감자사랑 » 06 Sep 2017 23:11
I'm sorry but it's not clear to me the situation you're explaining. Can you record it?
Always try the latest beta version (x32 only) before continuing a discussion here.
This is NOT official support though. It is my contribution to Potplayer.

Thread Subscription and E-mail Notification won't work at all.
Postby Dreamer » 07 Sep 2017 00:37
It would be not clear to see if it, since it's off screen. I found that window is adapted only if using this option:

Preferences > general > Skin overlay/zoom in > On screen control > "Disable"

Then use these options:

Preferences > general > startup > window size - custom 944x531
Preferences > general > startup > window position - custom *

* here the second number is 0 and the first must be 736 for the monitor resolution 1680x1050, for other resolution it's the monitor width minus 944. E.g.: for full HD (1920×1080) it's 1920-944=976.

Screenshots below are:
001 - at startup, main window height is adapted to title bar, moved down a bit
002 - start moving window to left, part of the playlist is visible
003 - moved the whole window left, playlist is fully visible, PP should start like this, to show all elements

(Images are resized, so it will be easier to display here, but I have also original size, if needed)

Image
Image
Image

BTW I think the window should be adapted also if option On screen control > is not "Disable", but other options are used, Direct3D 11...

Again, to always fix it at start - if you don't want to move the window manually, disable and enable Playlist.

EDIT: As I think about it, when using the option "Use Direct3D 11", title bar and navigation bar are auto-hidden, so perhaps also playlist should be, then adapting the window would not be needed at all.
Postby D2NP » 07 Sep 2017 01:32
In general this is the expected result
If you set Custom position --- that window will startup in this position
If you set Custom size --- the window will startup with a custom size
and
the "Window size" option sets the size of the video area (the area where the video is displayed), without taking into account the skin elements, including the attached playlist.

You need to change the custom position by the width of the playlist... 976 - ~320 (playlist width)
Or find another solution to use.
Postby Dreamer » 07 Sep 2017 03:17
Thanks, when I change the width, it works, but only with one size of playlist, when I resize playlist, it doesn't work good.

Anyway, it's not so important, I was just curious why the height is adapted and width not.
Postby Dreamer » 29 Nov 2017 10:05
OK, I got it! I thought the options for window size affects the video window, but two different options are available, so I can use these options:

General > startup > window position > 736x0
General > startup > window size > 544x531
Playback > default window size > 944x531

This way, when I start PP, main window is smaller (544x531), so playlist is visible, when I start any video, main window size is changed to 944x531, so it's right in the top-right corner, perfect!

I can't believe the solution has been here all the time.
6 posts Page 1 of 1

Login

Who is online

Users browsing this forum: No registered users and 1 guest