First unread post5 posts Page 1 of 1
Unread postby Yin Cognyto » 20 Jul 2018 06:22
Is it possible to get media's output audio infos like:
- audio " output codec", most often PCM
- bit / sample depth, most often 16-bit per sample
- output / rendering bitrate, most often 2 channels × 44.1 kHz × 16-bit per sample = 1411.2 kbps
So far, I've been able to get only the output sample rate and the output channels (i.e. CMD_AUDIO_OUT_SAMPLE_RATE_MESSAGE and CMD_AUDIO_OUT_NUM_CHANNEL_MESSAGE), but I can't find the commands to show the 3 infos I mentioned above, despite the fact that they are shown when pressing TAB for playback info.

If it's not possible, is there any chance for those to be included (or have skin support) in a future PotPlayer release?

P.S. Somewhat related to this, why is the string output of CMD_VIDEO_OUT_SIZE_MESSAGE something like 1920×-1080? Is that minus sign in front of 1080 normal?
Unread postby D2NP » 23 Jul 2018 03:29
Take a screenshot with the information (Tab) and mark what specific information you need.


"CMD_VIDEO_OUT_SIZE_MESSAGE"
all works fine, maybe Text='...' problem, or specific file type
Always try the latest beta version (x32 only) before continuing a discussion here.
When you have a problem (Follow steps 1,2,3)
This is NOT official support though. It is my contribution to Potplayer.
Unread postby Yin Cognyto » 23 Jul 2018 06:22
I need all the info from the Output (or Rendering, it doesn't matter) line in the Audio section - except, of course, CMD_AUDIO_OUT_SAMPLE_RATE_MESSAGE and CMD_AUDIO_OUT_NUM_CHANNEL_MESSAGE that you can already get the info from:
Image
P.S. Please check the test skin I posted in my other reply from "[BUG?] Tab selection button...", it has the problem with CMD_VIDEO_OUT_SIZE_MESSAGE as well, for multiple files I tested (MPEG TS, MP4, etc). By the way, I only noticed this now: during the first milliseconds, the video output resolution height appears without the minus, but after a very small delay, the minus appears. I tested without the Text='...' part and the issue happens this way too.
Unread postby D2NP » 24 Jul 2018 00:37
The Dev will not add these CmdID's,
but fixed the "minus" in new beta.
Always try the latest beta version (x32 only) before continuing a discussion here.
When you have a problem (Follow steps 1,2,3)
This is NOT official support though. It is my contribution to Potplayer.
Unread postby Yin Cognyto » 24 Jul 2018 01:27
Ok, thanks for the info. Great job fixing the minus issue too.
First unread post5 posts Page 1 of 1

Login

Who is online

Users browsing this forum: No registered users and 1 guest